FishingTN.com Tennessee's Fishing and Boating Community

Go Back   FishingTN.com Tennessee's Fishing and Boating Community > Fishing Discussion > Local Fishing
Register FAQ Members List Calendar Mark Forums Read
Google
 


Reply
 
Thread Tools
  #1  
Old 06-06-2018, 09:17 PM
navydocivan's Avatar
navydocivan navydocivan is offline
Junior Member
 
Join Date: Oct 2007
Location: GALLATIN
Posts: 66
Default Trouble with throttle

I just had my control box and cables changed and now when I go to get on plane I can floor it and. I only get 2.5k on my tach it will creep up to 3k then take off. But it tops out at 50mph vs 65 previously, mechanics say that the throttle is advancing the whole way but itís acting like I am not pushing throttle all the way open... Motor is a 175 Mercury yr is 98 and boat is a 98 ranger. Ohh with EFI He said it may just need plugs or. A fuel filter ... any you guys got any idea what may cause this ?
Reply With Quote
  #2  
Old 06-07-2018, 04:39 AM
Texas_Rig's Avatar
Texas_Rig Texas_Rig is offline
Senior Member
 
Join Date: Oct 2014
Location: Bethpage
Posts: 702
Default

Have you done a compression check?
Reply With Quote
  #3  
Old 06-07-2018, 10:14 AM
agelesssone's Avatar
agelesssone agelesssone is offline
nashvillefishingguides.co
 
Join Date: Jan 2012
Location: Goodlettsville, TN
Posts: 2,487
Default

https://www.yellowpages.com/hermitag...arine-26069923
Reply With Quote
  #4  
Old 06-07-2018, 11:21 AM
tkwalker's Avatar
tkwalker tkwalker is online now
Owner and Administrator
 
Join Date: Apr 2005
Location: Lebanon, Tennessee
Posts: 2,545
Smile Lebanon Area .. <'TK><

Larry Hagan, tell him I sent you ... 615-289-8620 ... <'TK><
Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 02:15 PM.


Site best viewed at 1280X1024
© FishingTN.com